InstancedGraphicParams Namespace
Function
Name | Description |
---|---|
InstancedGraphicParams.fromProps | Create an InstancedGraphicParams from an InstancedGraphicProps. |
InstancedGraphicParams.toProps | Convert params to a representation that can be copied using structured cloning. |
Defined in
InstancedGraphicParams Interface
Parameters for creating a RenderGraphic representing a collection of instances of shared geometry. Each instance is drawn using the same graphics, but with its own transform and (optionally) Feature Id.
Properties
Name | Type | Description | |
---|---|---|---|
count Readonly | number | The number of instances. | |
featureIds Readonly | Uint8Array | undefined | If defined, an array of little-endian 24-bit unsigned integers containing the feature ID of each instance. | |
range Readonly | Range3d | undefined | If defined, the combined range of all instances of the geometry. | |
symbologyOverrides Readonly | Uint8Array | undefined | If defined, as array of bytes (8 per instance) encoding the symbology overrides for each instance. | |
transformCenter Readonly | Point3d | A point roughly in the center of the range of all of the instances, to which each instance's translation is relative. | |
transforms Readonly | Float32Array | An array of instance-to-model transforms. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.