Gradient.Symb Class
Multi-color area fill defined by a range of colors that vary by position. Gradient fill can be applied to planar regions.
@see SymbProps
Methods
Name | Description | |
---|---|---|
constructor(): Gradient.Symb | ||
clone(): Gradient.Symb | ||
compare(other: Gradient.Symb): number | Compare this symbology to another. | |
equals(other: Gradient.Symb): boolean | Returns true if this symbology is equal to another, false otherwise. | |
getImage(width: number, height: number): ImageBuffer | Produces a bitmap image from this gradient. | |
mapColor(value: number): ColorDef | Maps a value to an RGBA value adjusted from a color present in this symbology's array. | |
produceImage(args: Gradient.ProduceImageArgs): ImageBuffer | Produces a bitmap image from this gradient. | |
toJSON(): Gradient.SymbProps | ||
compareSymb(lhs: Gradient.Symb, rhs: Gradient.Symb): number Static | Compares two gradient symbologies. | |
createThematic(settings: ThematicGradientSettings): Gradient.Symb Static | Create for ThematicDisplay. | |
fromJSON(json?: Gradient.SymbProps): Gradient.Symb Static | create a GradientSymb from a json object. |
Properties
Name | Type | Description | |
---|---|---|---|
angle | Angle | undefined | ||
flags | Gradient.Flags | ||
hasTranslucency Accessor ReadOnly | boolean | ||
isOutlined Accessor ReadOnly | boolean | Returns true if the Gradient.Flags.Outline flag is set. | |
keys | Gradient.KeyColor[] | ||
mode | Gradient.Mode | ||
shift | number | ||
thematicSettings | ThematicGradientSettings | undefined | ||
tint | number | undefined |
Defined in
- core/common/src/Gradient.ts Line 104
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.