Gradient.SymbProps Interface
Multi-color area fill defined by a range of colors that vary by position
Properties
Name | Type | Description | |
---|---|---|---|
angle | AngleProps | undefined | Gradient rotation angle, 0.0 if undefined | |
flags | Gradient.Flags | undefined | Gradient flags to enable outline display and invert color fractions, Flags.None if undefined | |
keys | Gradient.KeyColorProps[] | Gradient fraction value/color pairs, 1 minimum (uses tint for 2nd color), 8 maximum | |
mode | Gradient.Mode | Gradient type, must be set to something other than Gradient.Mode.None to display fill | |
shift | number | undefined | Gradient shift value from 0.0 to 1.0, 0.0 if undefined | |
thematicSettings | ThematicGradientSettingsProps | undefined | Settings applicable to ThematicDisplay. | |
tint | number | undefined | Gradient tint value from 0.0 to 1.0, only used when KeyColorProps size is 1, 0.0 if undefined |
Defined in
- core/common/src/Gradient.ts Line 69
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.