RenderGraphicOwner Class
A graphic that owns another graphic. By default, every time a Viewport's decorations or dynamics graphics change, the previous graphics are disposed of. Use a GraphicOwner to prevent disposal of a graphic that you want to reuse. The graphic owner can be added to decorations and list of dynamics just like any other graphic, but the graphic it owns will never be automatically disposed of. Instead, you assume responsibility for disposing of the owned graphic by calling disposeGraphic when the owned graphic is no longer in use. Failure to do so will result in leaks of graphics memory or other webgl resources.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): RenderGraphicOwner | ||
dispose(): void | Does nothing. | |
disposeGraphic(): void | Disposes of the owned graphic. |
Properties
Name | Type | Description | |
---|---|---|---|
graphic Accessor Abstract ReadOnly | RenderGraphic | The owned graphic. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.