RenderMaterial Namespace
Class
Name | Description |
---|---|
RenderMaterial.Params |
Defined in
RenderMaterial Class
Represents a material which can be applied to a surface to control aspects of its appearance such as color, reflectivity, texture, and so on.
Methods
Name | Description | |
---|---|---|
constructor(params: { key?: string, textureMapping?: TextureMapping }): RenderMaterial Protected | ||
compare(other: RenderMaterial): number | An OrderedComparator that compares this material against other . |
Properties
Name | Type | Description | |
---|---|---|---|
hasTexture Accessor ReadOnly | boolean | ||
key Readonly | string | undefined | If the material originated from a Material element in the IModelDb, the Id of that element. | |
textureMapping Readonly | TextureMapping | undefined | Describes how to map an image to a surface to which this material is applied. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.