TextureMapping Namespace
Enumeration
Name | Description |
---|---|
TextureMapping.Mode | Enumerates the possible texture mapping modes. |
Class
Name | Description |
---|---|
TextureMapping.Params | Parameters describing how a RenderTexture's image is mapped to a surface. |
TextureMapping.Trans2x3 | A 2x3 matrix for mapping a texture image to a surface. |
Interface
Name | Description |
---|---|
TextureMapping.ConstantLodParamProps | Properties used to construct a ConstantLodParams. |
TextureMapping.ConstantLodParams | Parameters to define constant level of detail mapping mode, a mode of texture coordinate generation which dynamically creates |
TextureMapping.ParamProps | Properties used to construct a TextureMapping.Params. |
Defined in
TextureMapping Class
Describes how to map a RenderTexture's image onto a surface as part of a RenderMaterial.
Methods
Name | Description | |
---|---|---|
constructor(tx: RenderTexture, params: TextureMapping.Params): TextureMapping | ||
compare(other: TextureMapping): number | An OrderedComparator that compares this mapping against other . |
Properties
Name | Type | Description | |
---|---|---|---|
normalMapParams | NormalMapParams | undefined | The parameters for normal mapping. | |
params Readonly | TextureMapping.Params | The parameters describing how the textures are mapped to the surface. | |
texture Readonly | RenderTexture | The texture to be mapped to the surface. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.