readGltfTemplate Function

Produce a GraphicTemplate from a glTF asset suitable for use in view decorations.

readGltfTemplate(args: ReadGltfGraphicsArgs): Promise<GltfTemplate | undefined>

@returns a template produced from the glTF asset's default scene, or undefined if a template could not be produced from the asset.

@see readGltf for more details.

Parameter Type Description
args ReadGltfGraphicsArgs  

Returns - Promise<GltfTemplate | undefined>

a template produced from the glTF asset's default scene, or undefined if a template could not be produced from the asset.

Defined in

Last Updated: 14 November, 2024