ReadGltfGraphicsArgs Interface
Arguments supplied to readGltfGraphics to produce a RenderGraphic from a glTF asset.
Properties
Name | Type | Description | |
---|---|---|---|
baseUrl | string | URL | The base URL for any relative URIs in the glTF. | |
gltf | object | Uint8Array | A representation of the glTF data as one of: | |
iModel | IModelConnection | The iModel with which the graphics will be associated - typically obtained from the Viewport into which they will be drawn. | |
pickableOptions | PickableGraphicOptions | undefined | Options for making the graphic pickable. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.