TerrainMeshProvider Class
Provides 3d meshes representing terrain for display in a Viewport.
Each mesh represents the terrain within a rectangular region of the Earth associated with a MapTile.
The display system drapes background map imagery onto these meshes.
TerrainMeshProvider
s are obtained from TerrainProviders.
@note A terrain mesh provider is expected to produce terrain for all areas of the globe. If it lacks terrain data for an area of the globe, it might choose to fall back to producing smooth terrain using an EllipsoidTerrainProvider.
@see - EllipsoidTerrainProvider for an example implementation that provides smooth terrain meshes.
- BingTerrainMeshProvider for an example implementation that produces 3d terrain meshes from elevations provided by BingElevationProvider.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): TerrainMeshProvider | ||
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void | Add attribution logo cards for the terrain data supplied by this provider to the Viewport's logo div. | |
forceTileLoad(_tile: MapTile): boolean | Returns true if the specified tile should always be loaded. | |
getChildHeightRange(quadId: QuadId, rectangle: MapCartoRectangle, parent: MapTile): undefined | Range1d | Returns the minimum and maximum elevation of the terrain within the specified region of the Earth. | |
isTileAvailable(_quadId: QuadId): boolean | Return whether terrain data can be obtained for the MapTile specified by quadId . |
|
readMesh(args: ReadMeshArgs): Promise<undefined | RealityMeshParams> Abstract | Convert the terrain data supplied by requestMeshData into a terrain mesh. | |
requestMeshData(args: RequestMeshDataArgs): Promise<any> Abstract | Obtain a representation of the terrain for a specific MapTile. |
Properties
Name | Type | Description | |
---|---|---|---|
maxDepth Accessor Abstract ReadOnly | number | Returns the maximum level of detail of the terrain meshes. | |
tilingScheme Accessor Abstract ReadOnly | MapTilingScheme | The tiling scheme used by this provider to convert between tile coordinates and geodetic coordinates. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.