BingElevationProvider Class
Provides an interface to the Bing Maps elevation services. Use of these services requires an API key to be supplied via BingMaps in the mapLayerOptions passed to startup.
Methods
Name | Description | |
---|---|---|
constructor(): BingElevationProvider | ||
getHeight(carto: Cartographic, geodetic: booleantrue): Promise<any> | Return the height (altitude) at a given cartographic location. | |
getHeightAverage(iModel: IModelConnection): Promise<number> | Get the average height (altitude) for a given iModel project extents. | |
getHeightRange(iModel: IModelConnection): Promise<Range1d> | Get the height (altitude) range for a given iModel project extents. | |
getHeights(range: Range2d): Promise<undefined | number[]> | Returns 256 elevations in the specified range - 16 rows and 16 columns. | |
getHeightValue(point: Point3d, iModel: IModelConnection, geodetic: booleantrue): Promise<number> | Get the height (altitude) at a given iModel coordinate. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.