RealityMeshParams Namespace
Defined in
RealityMeshParams Interface
Geometry for a reality mesh to be submitted to the RenderSystem for conversion to a RenderGraphic. A reality mesh is a simple triangle mesh to which a RenderTexture image can be mapped. Sources of reality meshes include TerrainMeshProviders to which background map imagery is applied, and ContextRealityModels captured using photogrammetry.
@see RealityMeshParamsBuilder to incrementally construct a RealityMeshParams
.
Properties
Name | Type | Description | |
---|---|---|---|
indices | UintArray | The integer indices of each triangle in the mesh. | |
normals | Uint16Array | undefined | The optional normal vector for each vertex in the mesh, indexed by indices, stored as OctEncodedNormals. | |
positions | QPoint3dBuffer | The 3d position of each vertex in the mesh, indexed by indices. | |
uvs | QPoint2dBuffer | The 2d texture coordinates of each vertex in the mesh, indexed by indices. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.