QPoint2dBuffer Namespace
Function
Name | Description |
---|---|
QPoint2dBuffer.getQPoint | Extracts the point at the specified index from a buffer. |
QPoint2dBuffer.unquantizePoint | Extracts and unquantizes the point at the specified index from a buffer. |
Defined in
- core/common/src/QPoint.ts Line 260
QPoint2dBuffer Interface
A compact representation of a list of QPoint2ds stored in a Uint16Array
This representation is particularly useful when passing data to WebGL; for example, see RealityMeshParams.uvs.
@see QPoint3dBuffer for 3d points.
Properties
Name | Type | Description | |
---|---|---|---|
params | QParams2d | The parameters used to quantize the points. | |
points | Uint16Array | The QPoint2ds as pairs of unsigned 16-bit integers. |
Defined in
- core/common/src/QPoint.ts Line 260
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.