MapTileTree Class
A quad tree consisting of MapTiles representing the map imagery draped onto the surface of the Earth.
A MapTileTree
enables display of a globe or planar map with map imagery obtained from any number of sources, such as
Bing, OpenStreetMap, and GIS servers.
The specific imagery displayed is determined by a Viewport's MapImagerySettings and BackgroundMapSettings.
The map or globe may be smooth, or feature 3d geometry supplied by a TerrainProvider. The terrain displayed in a Viewport is determined by its TerrainSettings.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
countTiles(): number Inherited | RealityTileTree | Returns the number of Tiles currently in memory belonging to this tree, primarily for debugging. |
dispose(): void Inherited | RealityTileTree | Dispose of this tree and any resources owned by it. |
getEcefTransform(): Promise<undefined | Transform> Inherited | RealityTileTree | Return the transform from the tile tree's coordinate space to ECEF (Earth Centered Earth Fixed) coordinates. |
selectTiles(args: TileDrawArgs): Tile[] Inherited | RealityTileTree | Selects tiles of appropriate resolution for some purpose like drawing to the screen, producing a shadow map, etc. |
Properties
Name | Type | Description | |
---|---|---|---|
globeMode Readonly | GlobeMode | Determines whether the map displays as a plane or an ellipsoid. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
batchTableProperties Accessor Inherited ReadOnly | undefined | BatchTableProperties | RealityTileTree | The mapping of per-feature JSON properties from this tile tree's batch table, if one is defined. |
contentRange Readonly Inherited | Range3d | undefined | RealityTileTree | Optional tight bounding box around the entire contents of all of this tree's tiles. |
expirationTime Readonly Inherited | BeDuration | RealityTileTree | The length of time after which tiles belonging to this tree are considered elegible for disposal if they are no longer in use. |
id Readonly Inherited | string | RealityTileTree | Uniquely identifies this tree among all other tile trees associated with the iModel. |
iModel Readonly Inherited | IModelConnection | RealityTileTree | |
iModelTransform Readonly Inherited | Transform | RealityTileTree | Transform from this tile tree's coordinate space to the iModel's coordinate space. |
is2d Accessor Inherited ReadOnly | boolean | RealityTileTree | True if this tile tree contains 2d graphics. |
isDisposed Accessor Inherited ReadOnly | boolean | RealityTileTree | True if dispose has been called on this tile tree. |
lastSelectedTime Accessor Inherited ReadOnly | BeTimePoint | RealityTileTree | The most recent time at which tiles selectTiles was called. |
modelId Readonly Inherited | string | RealityTileTree | A 64-bit identifier for this tile tree, unique within the context of its IModelConnection. |
range Accessor Inherited ReadOnly | Range3d | RealityTileTree | The volume of space occupied by this tile tree. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.