TerrainSettings Class
Normalized version of TerrainProps for which provider has been validated and default values of all members are used.
Methods
Name | Description | |
---|---|---|
constructor(props?: TerrainProps): TerrainSettings | ||
constructor(providerName?: string, exaggeration?: number, applyLighting?: boolean, heightOrigin?: number, heightOriginMode?: TerrainHeightOriginMode): TerrainSettings | Deprecated | |
clone(changedProps?: TerrainProps): TerrainSettings | Create a copy of this TerrainSettings, optionally modifying some of its properties. | |
equals(other: TerrainSettings): boolean | ||
equalsJSON(json?: BackgroundMapProps): boolean | Returns true if these settings are equivalent to the supplied JSON settings. | |
toJSON(): TerrainProps | ||
fromCesiumIonAsset(assetId: stringCesiumTerrainAssetId.Default, options?: Omit<TerrainProps, "providerName" | "dataSource">): TerrainSettings Static | Create settings that obtain terrain from a Cesium ION asset such as | |
fromJSON(json?: TerrainProps): TerrainSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
applyLighting Readonly | boolean | Applying lighting can help to visualize subtle terrain variations. | |
dataSource Readonly | string | Identifies the specific terrain data source to be supplied by the TerrainProvider identified by providerName, | |
exaggeration Readonly | number | A value greater than one will cause terrain height to be exaggerated/scaled. | |
heightOrigin Readonly | number | Origin value - height of the IModel origin at the project center as defined by heightOriginMode. | |
heightOriginMode Readonly | TerrainHeightOriginMode | Determines how/if the heightOrigin is applied to the terrain height. | |
providerName Readonly | string | Identifies the TerrainProvider that will supply terrain meshes. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.