BackgroundMapProps Interface
In-memory JSON representation of a BackgroundMapSettings.
@see PersistentBackgroundMapProps for the persistent JSON representation.
Properties
Name | Type | Description | |
---|---|---|---|
applyTerrain | boolean | undefined | If true, terrain heights will be applied to the map; otherwise the map will be rendered as a plane. | |
globeMode | GlobeMode | undefined | Globe Mode. | |
groundBias | number | undefined | The elevation of the map in meters relative the WGS84 ellipsoid. | |
nonLocatable | boolean | undefined | If true, the map will be treated as non-locatable - i.e., tools will not interact with it. | |
planarClipMask | PlanarClipMaskProps | undefined | A planar mask applied to the map geometry | |
providerData | undefined | undefined | See providerData. | |
providerName | undefined | undefined | See providerName. | |
terrainSettings | TerrainProps | undefined | Properties associated with terrain display. | |
transparency | number | "false" | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, or false to indicate the transparency should not be overridden. | |
useDepthBuffer | boolean | undefined | If set to true, the map tiles will be rendered with depth, allowing them to obscure other geometry. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.