TerrainProps Interface
JSON representation of the settings of the terrain applied to background map display by a DisplayStyle.
@see - DisplayStyleSettingsProps
Properties
Name | Type | Description | |
---|---|---|---|
applyLighting | boolean | undefined | Applying lighting can help to visualize subtle terrain variation. | |
dataSource | string | undefined | Identifies the specific terrain data source to be supplied by the TerrainProvider identified by providerName, | |
exaggeration | number | undefined | A value greater than one will cause terrain height to be exaggerated/scaled.false (or 1.0) indicate no exaggeration. | |
heightOrigin | number | undefined | Origin value - height of the IModel origin at the project center as defined by heightOriginMode. | |
heightOriginMode | TerrainHeightOriginMode | undefined | Determines how/if the heightOrigin is applied to the terrain height. | |
providerName | string | undefined | Identifies the TerrainProvider that will supply terrain meshes. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.