HitPath Interface
As part of a HitDetail, describes a series of "attached" views through which the hit was located. Typically, the contents of a view are rendered directly to the screen via viewport. However, in some contexts one view might be "attached" to the viewport's view via a ViewAttachment, SectionDrawing, or both. HitPath captures this information in one of the following possible ways:
- A SheetViewState renders another view through a ViewAttachment, in which case viewAttachment will be defined.
- A DrawingViewState renders a SpatialViewState through a SectionDrawing attachment, in which case sectionDrawingAttachment will be defined; or
- A combination of 1 and 2 where a ViewAttachment on a sheet renders a SectionDrawing with an attached SpatialViewState, in which both [viewAttachment]] and sectionDrawingAttachment will be defined.
Properties
Name | Type | Description | |
---|---|---|---|
sectionDrawingAttachment | SectionDrawingAttachmentHitInfo | undefined | Details about the SectionDrawing attachment through which the hit was obtained. | |
viewAttachment | ViewAttachmentHitInfo | undefined | Details about the ViewAttachment through which the hit was obtained. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.