RadialMenuProps Interface
Deprecated in 4.14.0. Props of deprecated component RadialMenu.
Properties for RadialMenu
Extends
Properties
Name | Type | Description | |
---|---|---|---|
children | React.ReactNode | undefined | Content | |
innerRadius | number | Radius of inner portion of RadialMenu | |
labelRotate | boolean | undefined | Whether to rotate labels according to location on the RadialMenu, or to keep labels upright. | |
left | string | number | Optional parameter to specify left position in viewport. | |
onBlur | (event: any) => any | undefined | triggered in case of onClick events anywhere other than radial menu | |
onEsc | (event: any) => any | undefined | triggered onKeyUp for |
|
opened | boolean | Whether to show RadialMenu | |
outerRadius | number | Radius of outer portion of RadialMenu | |
selected | number | undefined | Which child RadialButton to highlight | |
top | string | number | Optional parameter to specify top position in viewport. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.