Timer Class
Deprecated in 4.15.0. Used internally.
Notifies handler after a set interval.
Methods
Name | Description | |
---|---|---|
constructor(msDelay: number): Timer | Creates a new Timer. | |
setOnExecute(onExecute: ExecuteHandler): void | Set handler that is called after a set interval. | |
start(): void | Starts this Timer. | |
stop(): void | Stops this Timer. |
Properties
Name | Type | Description | |
---|---|---|---|
delay Accessor | number | Time interval in milliseconds after which handler will be notified. | |
isRunning Accessor ReadOnly | boolean | Indicates whether the timer is running |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.