MessageContainer Class
Deprecated in 4.15.0. Use [[iTwinUI Dialog]] instead.
Message Container React component.
Extends
- React.PureComponent<MessageContainerProps>
Methods
Name | Description | |
---|---|---|
render(): React.ReactElement<any, string | React.JSXElementConstructor<any>> | ||
getIcon(severity: MessageSeverity, hollow?: boolean): IconSpec Static | Returns the React icon corresponding to the MessageSeverity. | |
getIconClassName(severity: MessageSeverity): string Static | Returns the class name corresponding to the MessageSeverity. | |
getIconClassName(severity: MessageSeverity, hollow?: boolean): string Static | Returns the class name associated with the WebFont icon corresponding to the MessageSeverity. | Deprecated |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.