PopupProps Interface
Deprecated in 4.15.0. Props of deprecated Popup component.
Properties for the Popup component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
animate | boolean | undefined | Indicates whether to use animation for open/close (defaults to true) | |
ariaLabel | string | undefined | accessibility label | |
children | React.ReactNode | undefined | Content | |
closeOnContextMenu | boolean | undefined | Indicates whether to close the popup when the right mouse button is pressed (defaults to true) | |
closeOnEnter | boolean | undefined | Indicates whether to close the popup when Enter is pressed (defaults to true) | |
closeOnNestedPopupOutsideClick | boolean | undefined | If false outside click processing and closing are skipped if click occurs in another Popup component, default to false. | |
closeOnWheel | boolean | undefined | Indicates whether to close the popup when the wheel is used (defaults to true) | |
focusTarget | string | React.RefObject<HTMLElement> | Element to receive focus, specified by React.RefObject or CSS selector string. | |
isOpen | boolean | Indicates whether the popup is shown or not (defaults to false) | |
isPinned | boolean | undefined | Indicates whether the popup is pinned. | |
keepContentsMounted | boolean | undefined | If true the children are mounted once and unmounted when this component is unmounted. | |
left | number | Left position (absolute positioning - defaults to 0) | |
moveFocus | boolean | undefined | set focus to popup - default to not set focus | |
offset | number | Offset from the parent (defaults to 4) | |
onClose | () => void | undefined | Function called when the popup is closed | |
onContextMenu | (e: MouseEvent) => void | undefined | Function called when the right mouse button is pressed | |
onEnter | () => void | undefined | Function called when the popup is closed on Enter | |
onOpen | () => void | undefined | Function called when the popup is opened | |
onOutsideClick | (e: MouseEvent) => void | undefined | Function called when user clicks outside the popup | |
onWheel | (e: WheelEvent) => void | undefined | Function called when the wheel is used | |
portalTarget | HTMLElement | undefined | Target that should be used when portaling popup. | |
position | RelativePosition | Direction (relative to the target) to which the popup is expanded (defaults to Bottom) | |
repositionOnResize | boolean | undefined | If true the popup will remain open and will be repositioned when window resize events occur, default to false. | |
role | "dialog" | "alert" | "alertdialog" | Role - if not specified "dialog" is used | |
showArrow | boolean | Show or hide the arrow (defaults to false) | |
showShadow | boolean | Show or hide the box shadow (defaults to true) | |
target | "null" | HTMLElement | Target element to position popup | |
top | number | Top position (absolute positioning - defaults to 0) |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.