IconInputProps Interface
Deprecated in 4.12.0. Props of deprecated component IconInput.
Properties for the IconInput component
Extends
Properties
Name |
Type |
Description |
|
containerClassName |
string | undefined |
CSS class name for the IconInput component container div |
|
icon |
React.ReactNode |
Icon displayed to the left of the Input field within the IconInput component |
|
ref |
React.Ref<HTMLInputElement> | undefined |
Provides ability to return reference to HTMLInputElement |
|
size |
"small" | "large" |
Modify size of the input. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
string | undefined |
Omit |
Optional unique identifier for item. |
nativeKeyHandler |
(e: KeyboardEvent) => void | undefined |
Omit |
Native keydown event handler |
setFocus |
boolean | undefined |
Omit |
Indicates whether to set focus to the input element |
Defined in
Last Updated: 14 November, 2024