NumberInputProps Interface

Deprecated  in 4.12.0. Props of deprecated component NumberInput.

Properties for the NumberInput component

Extends

  • Omit<InputProps, "min" | "max" | "step" | "onChange">

Properties

Name Type Description
containerClassName string | undefined CSS class name for the NumberInput component container div  
containerStyle React.CSSProperties | undefined Style for component container div.  
format (num: "null" | number, formattedValue: string) => string | undefined function optional formatting function that takes the number value and the internal formatted value in case function just adds prefix or suffix.  
max number | undefined number or function defaults to Number.MAX_SAFE_INTEGER  
min number | undefined number or function Number.MIN_SAFE_INTEGER  
onChange (value: number, stringValue: string) => void | undefined Function to call when value is changed.  
parse (value: string) => undefined | "null" | number | undefined function parseFloat  
precision number | undefined number of decimal places, defaults to 0  
ref React.Ref<HTMLInputElement> | undefined Provides ability to return reference to HTMLInputElement  
showTouchButtons boolean | undefined if true up/down buttons are shown larger and side by side  
snap boolean | undefined Set to true to "snap" to the closest step value while incrementing or decrementing (up/down buttons or arrow keys).  
step StepFunctionProp | undefined increment step value used while incrementing or decrementing (up/down buttons or arrow keys) defaults to 1.  
value number | undefined Numeric value, set to undefined to show placeholder text  

Defined in

Last Updated: 14 November, 2024