useSaveBeforeClosingSettingsContainer Function
Deprecated in 4.16.0. Use SettingsManager instead.
Hook to use within Settings Page component to allow saving the current page's data before the Setting Container is closed.
useSaveBeforeClosingSettingsContainer(settingsManager: SettingsManager, saveFunction: (closeFunc: (args: any) => void, closeFuncArgs?: any) => void): void
Parameter | Type | Description |
---|---|---|
settingsManager | SettingsManager | |
saveFunction | (closeFunc: (args: any) => void, closeFuncArgs?: any) => void |
Returns - void
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.