MainTabsProps Interface
Deprecated in 4.12.0. Props of deprecated component Tabs.
Properties for the base Tabs component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
mainClassName | string | Main CSS class name | |
orientation | Orientation | Orientation of the Tabs list |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
activeIndex | number | undefined | TabsProps | Index of the initial active tab |
green | boolean | undefined | TabsProps | Indicates whether the bar on the active tab is green instead of the default blue |
itemId | string | undefined | TabsProps | Optional unique identifier for item. |
labels | string | TabLabel[] | TabsProps | Text shown for each tab |
onActivateTab | (index: number) => any | undefined | TabsProps | Handler for activating a tab |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.