TabsProps Interface
Deprecated in 4.12.0. Props of deprecated component Tabs.
Properties for the VerticalTabs component
Extends
- React.AllHTMLAttributes<HTMLUListElement>
- CommonProps
Properties
Name | Type | Description | |
---|---|---|---|
activeIndex | number | undefined | Index of the initial active tab | |
green | boolean | undefined | Indicates whether the bar on the active tab is green instead of the default blue | |
labels | string | TabLabel[] | Text shown for each tab | |
onActivateTab | (index: number) => any | undefined | Handler for activating a tab |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.