NodeCheckboxProps Interface
Deprecated in 4.15.0. Used in deprecated TreeNodeProps props.
Properties for Tree Node CheckBox
Properties
Name | Type | Description | |
---|---|---|---|
isDisabled | boolean | undefined | Indicates whether checkbox is disabled | |
onClick | (newState: CheckBoxState) => void | undefined | Click event callback | |
state | CheckBoxState | undefined | State of the checkbox | |
tooltip | string | undefined | Tooltip to be displayed when mouse is hovered over checkbox |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.