InputLabelProps Interface
Deprecated in 4.12.0. Props of deprecated component InputLabel.
Properties for InputLabel components
Extends
Properties
Name | Type | Description | |
---|---|---|---|
children | React.ReactNode | undefined | Labeled content | |
disabled | boolean | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
inputClassName | string | undefined | LabeledComponentProps | Custom CSS class name for the checkbox input element |
inputStyle | React.CSSProperties | undefined | LabeledComponentProps | Custom CSS Style for the checkbox input element |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
label | string | undefined | LabeledComponentProps | Text that will be shown next to or above the input. |
labelClassName | string | undefined | LabeledComponentProps | Custom CSS class name for the label |
labelStyle | React.CSSProperties | undefined | LabeledComponentProps | Custom CSS Style for the label |
string | undefined | MessagedComponentProps | Optional text shown below the input. | |
string | undefined | MessagedComponentProps | Custom CSS class name for the message | |
React.CSSProperties | undefined | MessagedComponentProps | Custom CSS Style for the message | |
status | InputStatus | undefined | LabeledComponentProps | Input status like: "Success", "Warning" or "Error" |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.