GlobalContextMenuProps Interface

Deprecated  in 4.16.0. Props of deprecated GlobalContextMenu component.

Properties for the GlobalContextMenu component

Extends

Properties

Name Type Description
contextMenuComponent React.ComponentType<ContextMenuProps> | undefined Context menu element.  
identifier string | undefined Unique identifier, to distinguish from other GlobalContextMenu components.  
x string | number Specifies the x/horizontal position on the viewport.  
y string | number Specifies the y/vertical position on the viewport.  

Inherited properties

Name Type Inherited from Description
autoflip Inherited boolean | undefined ContextMenuProps Whether menu flips directions based on screen edge.
children Inherited React.ReactNode | undefined ContextMenuProps Content
className Inherited string | undefined ContextMenuProps Custom CSS class name
direction Inherited ContextMenuDirection | undefined ContextMenuProps Which direction the menu opens.
edgeLimit Inherited boolean | undefined ContextMenuProps Whether menu hugs screen edge when autoflip is off.
floating Inherited boolean | undefined ContextMenuProps whether menu floats on the viewport, or the page.
hotkeySelect Inherited boolean | undefined ContextMenuProps Whether Hotkey press selects item, or just highlights item.
itemId Inherited string | undefined ContextMenuProps Optional unique identifier for item.
onEsc Inherited (data: any) => any | undefined ContextMenuProps when Escape button is pressed
onOutsideClick Inherited (event: MouseEvent) => any | undefined ContextMenuProps When click is registered outside of ContextMenu.
onSelect Inherited (event: any) => any | undefined ContextMenuProps When list item or submenu is selected
opened Inherited boolean ContextMenuProps Whether ContextMenu is currently opened.
selectedIndex Inherited number | undefined ContextMenuProps starting menu item selected index Default: -1
style Inherited React.CSSProperties | undefined ContextMenuProps Custom CSS style properties

Defined in

Last Updated: 14 March, 2025