SettingsTabEntry Interface
Deprecated in 4.16.0. Use ($@itwin/appui-react#SettingsTabEntry$refLinkSource=core-react/ui/core-react/src/core-react/settings/SettingsManager.tsx@19) instead.
Interface used to populate a tab entry in the SettingContainer control
Properties
Name | Type | Description | |
---|---|---|---|
icon Readonly | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Icon specification | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Allows Settings entry to be disabled | |
itemPriority Readonly | number | used to determine position in tablist | |
label Readonly | string | localized display label | |
page Readonly | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Setting page content to display when tab item is selected. | |
pageWillHandleCloseRequest Readonly | boolean | undefined | Setting to true if page will register to watch for stage closing event so it can save any dirty settings. | |
subLabel Readonly | string | undefined | Optional Subtitle to show below label. | |
tabId Readonly | string | unique id for entry | |
tooltip Readonly | string | React.ReactElement<any, string | React.JSXElementConstructor<any>> | Tooltip. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.