CheckListBoxItemProps Interface

Deprecated  in 4.12.x. Props of deprecated component CheckListBoxItem.

Properties for the CheckListBoxItem component

Extends

Properties

Name Type Description
checked boolean | undefined Indicates whether the item is checked or not  
disabled boolean | undefined Indicates whether the item is disabled or not  
label string Label  
onChange (e: React.ChangeEvent<HTMLInputElement>) => any | undefined Function called when item is changed.  
onClick () => any | undefined Function called when item is clicked.  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 23 May, 2024