RadialButtonProps Interface
Deprecated in 4.14.0. Props of deprecated component RadialButton.
Properties for RadialButton component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
children | React.ReactNode | undefined | Content | |
icon | IconSpec | undefined | which icon to display in on the menu button | |
labelRotate | boolean | undefined | Whether label is rotated to radial menu. | |
onSelect | (e: any) => any | undefined | listens to any onClick event, or any select event, which can be triggered by the select() method. | |
selected | boolean | undefined | Whether item is highlighted |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | string | undefined | CommonProps | Custom CSS class name |
itemId | string | undefined | CommonProps | Optional unique identifier for item. |
style | React.CSSProperties | undefined | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.