GeometryStreamEntryProps Interface
Allowed GeometryStream entries - should only set one value.
@see GeometryStream
Extends
Properties
Name | Type | Description | |
---|---|---|---|
appearance | GeometryAppearanceProps | undefined | ||
brep | BRepEntity.DataProps | undefined | ||
fill | AreaFillProps | undefined | ||
geomPart | GeometryPartInstanceProps | undefined | ||
header | GeometryStreamHeaderProps | undefined | ||
image | ImageGraphicProps | undefined | ||
material | MaterialProps | undefined | ||
pattern | AreaPattern.ParamsProps | undefined | ||
styleMod | LineStyle.ModifierProps | undefined | ||
subRange | Readonly<WritableLowAndHighXYZ> | undefined | ||
textString | TextStringProps | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc Inherited | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | GeomJson.GeometryProps | {arc:...} |
bagofCurves Inherited | [IModelJson.CurveCollectionProps] | undefined | GeomJson.GeometryProps | A collection of curves with no required structure or connections: |
bcurve Inherited | IModelJson.BcurveProps | undefined | GeomJson.GeometryProps | {bcurve:...} |
box Inherited | IModelJson.BoxProps | undefined | GeomJson.GeometryProps | {box:...} |
bsurf Inherited | IModelJson.BSplineSurfaceProps | undefined | GeomJson.GeometryProps | {bsurf:...} |
cone Inherited | IModelJson.ConeProps | undefined | GeomJson.GeometryProps | {cone:............} |
cylinder Inherited | IModelJson.CylinderProps | undefined | GeomJson.GeometryProps | {cylinder:...} |
indexedMesh Inherited | IModelJson.IndexedMeshProps | undefined | GeomJson.GeometryProps | {indexedMesh:...} |
interpolationCurve Inherited | InterpolationCurve3dProps | undefined | GeomJson.GeometryProps | `{interpolationCurve:...}~ |
linearSweep Inherited | IModelJson.LinearSweepProps | undefined | GeomJson.GeometryProps | {linearSweep:.........} |
lineSegment Inherited | [XYZProps, XYZProps] | undefined | GeomJson.GeometryProps | {lineSegment:...} |
lineString Inherited | XYZProps[] | undefined | GeomJson.GeometryProps | {lineString:...} |
loop Inherited | [IModelJson.CurvePrimitiveProps] | undefined | GeomJson.GeometryProps | {loop:...} |
parityRegion Inherited | [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined | GeomJson.GeometryProps | {parityRegion:...} |
path Inherited | [IModelJson.CurvePrimitiveProps] | undefined | GeomJson.GeometryProps | A sequence of curves joined head to tail: |
point Inherited | XYZProps | undefined | GeomJson.GeometryProps | {point:...} |
pointString Inherited | XYZProps[] | undefined | GeomJson.GeometryProps | {pointString:...} |
rotationalSweep Inherited | IModelJson.RotationalSweepProps | undefined | GeomJson.GeometryProps | {rotationalSweep:...} |
ruledSweep Inherited | IModelJson.RuledSweepProps | undefined | GeomJson.GeometryProps | {ruledSweep:...} |
sphere Inherited | IModelJson.SphereProps | undefined | GeomJson.GeometryProps | {sphere:............} |
torusPipe Inherited | IModelJson.TorusPipeProps | undefined | GeomJson.GeometryProps | {torusPipe:............} |
transitionSpiral Inherited | IModelJson.TransitionSpiralProps | undefined | GeomJson.GeometryProps | {transitionSpiral:...} |
unionRegion Inherited | [IModelJson.PlanarRegionProps] | undefined | GeomJson.GeometryProps | {unionRegion:...} |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.