IModelJson.BoxProps Interface
Interface for Box (or frustum with all rectangular sections parallel to primary xy section).
- Orientation may be given in any
AxesProps
way (yawPitchRollAngles
,xyVectors
,zxVectors
). - If
topX
ortopY
are omitted, each defaults to itsbaseX
orbaseY
peer. - If
topOrigin
is given,height
is unused. - If
topOrigin
is omitted andheight
is given,topOrigin
is computed along the z axis at distanceheight
. - If both
topOrigin
andheight
are omitted,height
defaults tobaseX
, andtopOrigin
is computed as above.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
baseX | number | base x size (required) | |
baseY | number | undefined | base y size. | |
capped | boolean | undefined | optional capping flag. | |
height | number | undefined | optional height. | |
origin | XYZProps | Origin of the box coordinate system (required) | |
topOrigin | XYZProps | undefined | top origin. | |
topX | number | undefined | x size on top section. | |
topY | number | undefined | y size on top section. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | YawPitchRollProps | undefined | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 390
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.