IModelJson.ConeProps Interface
Interface for Cone value defined by centers, radii, and (optional) vectors for circular section planes.
- VectorX and vectorY are optional.
- If either one is missing, both vectors are constructed perpendicular to the vector from start to end.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
capped | boolean | undefined | flag for circular end caps. | |
end | XYZProps | Point on axis at end section | |
endRadius | number | undefined | radius at end section |
|
radius | number | undefined | single radius to be applied as both start and end | |
start | XYZProps | Point on axis at start section. | |
startRadius | number | undefined | radius at start section |
|
vectorX | XYZProps | undefined | optional x vector in start section. | |
vectorY | XYZProps | undefined | optional y vector in start section. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | YawPitchRollProps | undefined | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | [XYZProps, XYZProps] | undefined | IModelJson.AxesProps | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 243
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.