IModelJson.CurvePrimitiveProps Interface
Property rules for json objects that can be deserialized to various CurvePrimitives
- Only one of these is allowed in each instance.
Properties
Name | Type | Description | |
---|---|---|---|
arc | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | {arc:...} |
|
bcurve | IModelJson.BcurveProps | undefined | {bcurve:...} |
|
interpolationCurve | InterpolationCurve3dProps | undefined | `{interpolationCurve:...}~ | |
lineSegment | [XYZProps, XYZProps] | undefined | {lineSegment:...} |
|
lineString | XYZProps[] | undefined | {lineString:...} |
|
transitionSpiral | IModelJson.TransitionSpiralProps | undefined | {transitionSpiral:...} |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.