InterpolationCurve3dProps Interface
fitPoints and end condition data for InterpolationCurve3d
- This is a "json compatible" version of InterpolationCurve3dOptions
Properties
Name | Type | Description | |
---|---|---|---|
closed | boolean | undefined | true if the B-spline construction should be periodic | |
endTangent | XYZProps | undefined | optional end tangent, pointing into curve. | |
fitPoints | XYZProps[] | points that the curve must pass through | |
isChordLenKnots | number | undefined | if closed and no knots, compute chord length knots (1) or uniform knots (0). | |
isChordLenTangents | number | undefined | if !closed and start/endTangent is given, set its magnitude to the first/last fit point chord length (1) or to the magnitude of the Bessel tangent (0). | |
isColinearTangents | number | undefined | if !closed but first and last fitPoints are equal, pivot computed start/end tangent(s) so that they are colinear (1) or leave them be (0). | |
isNaturalTangents | number | undefined | if !closed and start/endTangent is absent, compute it using the natural end condition (1) or Bessel (0). | |
knots | number[] | undefined | parameters for curve fitting, one per fit point | |
order | number | undefined | order of the computed bspline (one more than degree) | |
startTangent | XYZProps | undefined | optional start tangent, pointing into curve. |
Defined in
- bspline/InterpolationCurve3d.ts Line 26
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.