AreaPattern.ParamsProps Interface
Definition of a hatch, cross-hatch, or area pattern that can be applied to the interior of a planar region.
Properties
Name | Type | Description | |
---|---|---|---|
angle1 | AngleProps | undefined | Angle of first set of parallel lines in a hatch pattern or area pattern tile direction, 0.0 if undefined | |
angle2 | AngleProps | undefined | Angle of second set of parallel lines in a cross-hatch, 0.0 if undefined | |
color | number | undefined | Pattern color, leave undefined to inherit color from parent element. | |
defLines | AreaPattern.HatchDefLineProps[] | undefined | Define an area pattern by supplying hatch line definitions instead of using a GeometryPart | |
invisibleBoundary | boolean | undefined | Set to inhibit display of pattern boundary, not applicable when boundary is also filled, false if undefined | |
origin | XYZProps | undefined | Pattern offset (relative to placement), 0.0,0.0,0.0 if undefined | |
rotation | YawPitchRollProps | undefined | Pattern orientation (relative to placement), 0.0,0.0,0.0 if undefined | |
scale | number | undefined | Scale to apply to area pattern symbol, 1.0 if undefined | |
snappable | boolean | undefined | Set to allow snapping to pattern geometry, false if undefined | |
space1 | number | undefined | Spacing of first set of parallel lines in a hatch pattern, or row spacing between area pattern tiles, 0.0 if undefined | |
space2 | number | undefined | Spacing of second set of parallel lines in a cross-hatch (leave undefined or 0 for a hatch), or column spacing between area pattern tiles, 0.0 if undefined | |
symbolId | string | undefined | GeometryPart id to use for tiled area pattern display | |
weight | number | undefined | Pattern weight, leave undefined to inherit weight from parent element. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.