IModelJson.GeometryProps Interface
Property rules for json objects that can be deserialized to various Curve and Solid objects
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bsurf | IModelJson.BSplineSurfaceProps | undefined | {bsurf:...} |
|
indexedMesh | IModelJson.IndexedMeshProps | undefined | {indexedMesh:...} |
|
point | XYZProps | undefined | {point:...} |
|
pointString | XYZProps[] | undefined | {pointString:...} |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | IModelJson.CurvePrimitiveProps | {arc:...} |
bagofCurves | [IModelJson.CurveCollectionProps] | undefined | CurveCollectionProps | A collection of curves with no required structure or connections: |
bcurve | IModelJson.BcurveProps | undefined | IModelJson.CurvePrimitiveProps | {bcurve:...} |
box | IModelJson.BoxProps | undefined | SolidPrimitiveProps | {box:...} |
cone | IModelJson.ConeProps | undefined | SolidPrimitiveProps | {cone:............} |
cylinder | IModelJson.CylinderProps | undefined | SolidPrimitiveProps | {cylinder:...} |
interpolationCurve | InterpolationCurve3dProps | undefined | IModelJson.CurvePrimitiveProps | `{interpolationCurve:...}~ |
lineSegment | [XYZProps, XYZProps] | undefined | IModelJson.CurvePrimitiveProps | {lineSegment:...} |
lineString | XYZProps[] | undefined | IModelJson.CurvePrimitiveProps | {lineString:...} |
linearSweep | IModelJson.LinearSweepProps | undefined | SolidPrimitiveProps | {linearSweep:.........} |
loop | [IModelJson.CurvePrimitiveProps] | undefined | CurveCollectionProps | {loop:...} |
parityRegion | [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined | CurveCollectionProps | {parityRegion:...} |
path | [IModelJson.CurvePrimitiveProps] | undefined | CurveCollectionProps | A sequence of curves joined head to tail: |
rotationalSweep | IModelJson.RotationalSweepProps | undefined | SolidPrimitiveProps | {rotationalSweep:...} |
ruledSweep | IModelJson.RuledSweepProps | undefined | SolidPrimitiveProps | {ruledSweep:...} |
sphere | IModelJson.SphereProps | undefined | SolidPrimitiveProps | {sphere:............} |
torusPipe | IModelJson.TorusPipeProps | undefined | SolidPrimitiveProps | {torusPipe:............} |
transitionSpiral | IModelJson.TransitionSpiralProps | undefined | IModelJson.CurvePrimitiveProps | {transitionSpiral:...} |
unionRegion | [IModelJson.PlanarRegionProps] | undefined | CurveCollectionProps | {unionRegion:...} |
Defined in
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.