IModelJson.CurveCollectionProps Interface
Interface for a collection of curves, eg. as used as a swept contour.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bagofCurves | [IModelJson.CurveCollectionProps] | undefined | A collection of curves with no required structure or connections: | |
path | [IModelJson.CurvePrimitiveProps] | undefined | A sequence of curves joined head to tail: |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
loop | [IModelJson.CurvePrimitiveProps] | undefined | IModelJson.PlanarRegionProps | {loop:...} |
parityRegion | [{ loop: [IModelJson.CurvePrimitiveProps] }] | undefined | IModelJson.PlanarRegionProps | {parityRegion:...} |
unionRegion | [IModelJson.PlanarRegionProps] | undefined | IModelJson.PlanarRegionProps | {unionRegion:...} |
Defined in
- serialization/IModelJsonSchema.ts Line 133
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.