IModelJson.IndexedMeshProps Interface
Interface for an indexed mesh.
- IMPORTANT: All indices are one-based.
- i.e. vertex index given as 11 appears at index 10 in the data array.
- This is to allow a negated index to mean "don't draw the following edge"
- Although negative indices are not allowed for normalIndex, colorIndex, or paramIndex, the "one based" style is used for them so that all indices within the indexedMesh json object are handled similarly.
- In all index arrays, a ZERO indicates "end of facet".
Properties
Name | Type | Description | |
---|---|---|---|
auxData | IModelJson.AuxDataProps | undefined | Optional analytical data at the vertices of the mesh | |
color | [number] | undefined | 32 bit color values | |
colorIndex | [number] | undefined | ONE BASED ZERO TERMINATED array of color indices. | |
expectedClosure | number | undefined | Indicates if mesh closure is unknown (0 | undefined), open sheet (1), or closed solid (2). | |
normal | [XYZProps] | undefined | surface normals | |
normalIndex | [number] | undefined | ONE BASED ZERO TERMINATED array of normal indices. | |
numPerFace | number | undefined | Optional fixed block size for indices. | |
param | [XYProps] | undefined | texture space (uv parameter) coordinates | |
paramIndex | [number] | undefined | ONE BASED ZERO TERMINATED array of param indices. | |
point | [XYZProps] | vertex coordinates | |
pointIndex | [number] | SIGNED ONE BASED ZERO TERMINATED array of point indices. | |
tags | IModelJson.TaggedNumericDataProps | undefined | Optional array of tagged geometry (such as to request subdivision surface) | |
twoSided | boolean | undefined | Optional flag indicating if mesh display must assume both sides are visible. |
Defined in
- serialization/IModelJsonSchema.ts Line 552
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.