GeometryAppearanceProps Interface
Establish a non-default SubCategory or to override SubCategoryAppearance for the geometry that follows. A GeometryAppearanceProps always signifies a reset to the SubCategoryAppearance for subsequent GeometryStreamProps entries for undefined values.
Properties
Name | Type | Description | |
---|---|---|---|
color | number | undefined | Optional color to override SubCategoryAppearance.color for subsequent geometry. | |
displayPriority | number | undefined | Optional display priority (2d only), 0 if undefined. | |
geometryClass | GeometryClass | undefined | Optional GeometryClass (for DGN compatibility, subCategories preferred), Primary if undefined. | |
style | string | undefined | Optional style to override styleId for subsequent geometry. | |
subCategory | string | undefined | Optional SubCategory id for subsequent geometry. | |
transparency | number | undefined | Optional transparency, 0.0 if undefined. | |
weight | number | undefined | Optional weight to override SubCategoryAppearance.weight for subsequent geometry. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.