LineStyle.ModifierProps Interface
Modify the line style appearance without changing the line style definition. Applies to the style previously established by a GeometryAppearanceProps or current SubCategoryAppearance. Most of the modifiers affect the line style stroke pattern, with the orientation and scales being the exception.
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
centerPhase | boolean | undefined | Optional flag to center stroke pattern and stretch ends, false if undefined | |
dashScale | number | undefined | Optional scale to apply to scalable dashes, 1.0 if undefined | |
distPhase | number | undefined | Optional shift by distance in meters, 0.0 if undefined | |
endWidth | number | undefined | Optional end width in meters to apply to dashes, same as startWidth if undefined | |
fractPhase | number | undefined | Optional shift by fraction, 0.0 if undefined | |
gapScale | number | undefined | Optional scale to apply to scalable gaps, 1.0 if undefined | |
normal | XYZProps | undefined | Optional up vector for style (applicable to 3d only), 0.0,0.0,1.0 if undefined | |
physicalWidth | boolean | undefined | Optional flag that denotes startWidth and endWidth represent physical widths that should not be affected by scale, false if undefined | |
rotation | YawPitchRollProps | undefined | Optional orientation for style (applicable to 3d only), 0.0,0.0,0.0 if undefined | |
scale | number | undefined | Optional scale to apply to all length values, 1.0 if undefined | |
segmentMode | boolean | undefined | Optional flag to enable or disable single segment mode | |
startWidth | number | undefined | Optional start width in meters to apply to dashes, no width if undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.