ImageryMapLayerTreeReference Class
A reference to one of our tile trees. The specific TileTree drawn may change when the desired imagery type or target iModel changes.
Extends
Methods
Name | Description | |
---|---|---|
constructor(args: { iModel: IModelConnection, layerIndex: number, layerSettings: MapLayerSettings }): ImageryMapLayerTreeReference | Constructor for an ImageryMapLayerTreeReference. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_collectTileGeometry(collector: TileGeometryCollector): void Protected Inherited | MapLayerTileTreeReference | A function that can be assigned to collectTileGeometry to enable geometry collection for references to tile trees that support geometry collection. |
_createGeometryTreeReference(): undefined | GeometryTileTreeReference Protected Inherited | MapLayerTileTreeReference | Create a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry. |
accumulateTransformedRange(range: Range3d, matrix: Matrix4d, frustumPlanes?: FrustumPlanes): void Inherited | MapLayerTileTreeReference | |
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void Inherited | MapLayerTileTreeReference | Add attribution logo cards for the tile tree source logo cards to the viewport's logo div. |
addToScene(context: SceneContext): void Inherited | MapLayerTileTreeReference | Adds this reference's graphics to the scene. |
canSupplyToolTip(hit: HitDetail): boolean Inherited | MapLayerTileTreeReference | Return whether this TileTreeReference can supply a tooltip describing the entity represented by the specified hit. |
collectStatistics(stats: RenderMemory.Statistics): void Inherited | MapLayerTileTreeReference | Record graphics memory consumed by this tile tree reference. |
computeTransform(tree: TileTree): Transform Protected Inherited | MapLayerTileTreeReference | Compute a transform from this tile tree reference's coordinate space to the IModelConnection's coordinate space. |
computeWorldContentRange(): Range3d Inherited | MapLayerTileTreeReference | Compute the range of this tile tree's contents in world coordinates. |
createDrawArgs(context: SceneContext): undefined | TileDrawArgs Inherited | MapLayerTileTreeReference | Create context for drawing the tile tree, if it is ready for drawing. |
createGeometryTreeReference(): undefined | GeometryTileTreeReference Inherited | MapLayerTileTreeReference | Obtain a tile tree reference equivalent to this one that also supplies an implementation of collectTileGeometry, or |
decorate(_context: DecorateContext): void Inherited | MapLayerTileTreeReference | Optionally add any decorations specific to this reference. |
discloseTileTrees(trees: DisclosedTileTreeSet): void Inherited | MapLayerTileTreeReference | Disclose all TileTrees use by this reference. |
draw(args: TileDrawArgs): void Inherited | MapLayerTileTreeReference | Adds this reference's graphics to the scene. |
getAppearanceProvider(_tree: TileTree): undefined | FeatureAppearanceProvider Protected Inherited | MapLayerTileTreeReference | Return a provider that can supplement the view's symbology overrides. |
getClipVolume(tree: TileTree): undefined | RenderClipVolume Protected Inherited | MapLayerTileTreeReference | Return the clip volume applied to this reference's tile tree, if any. |
getHiddenLineSettings(_tree: TileTree): undefined | HiddenLine.Settings Protected Inherited | MapLayerTileTreeReference | Return hidden line settings to replace those defined for the view. |
getLocation(): undefined | Transform Inherited | MapLayerTileTreeReference | Supply transform from this tile tree reference's location to iModel coordinate space. |
getSymbologyOverrides(_tree: TileTree): undefined | FeatureSymbology.Overrides Protected Inherited | MapLayerTileTreeReference | Return overrides that replace any defined for the view. |
getToolTip(hit: HitDetail): Promise<undefined | string | HTMLElement> Inherited | MapLayerTileTreeReference | Return a tooltip describing the hit, or undefined if no tooltip can be supplied. |
getToolTipPromise(hit: HitDetail): undefined | Promise<undefined | string | HTMLElement> Inherited | MapLayerTileTreeReference | Obtain a tooltip describing the specified hit , or undefined if this tile tree reference cannot supply a tooltip for the hit. |
getTransformFromIModel(): undefined | Transform Inherited | MapLayerTileTreeReference | |
getViewFlagOverrides(tree: TileTree): Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> Protected Inherited | MapLayerTileTreeReference | Supply overrides that should be applied to the ViewState's ViewFlags when drawing this tile tree reference. |
unionFitRange(union: Range3d): void Inherited | MapLayerTileTreeReference | Unions this reference's range with the supplied range to help compute a volume in world space for fitting a viewport to its contents. |
createFromRenderGraphic(args: RenderGraphicTileTreeArgs): TileTreeReference Static Inherited | MapLayerTileTreeReference | Create a TileTreeReference that displays a pre-defined RenderGraphic. |
Properties
Name | Type | Description | |
---|---|---|---|
castsShadows Accessor ReadOnly | boolean | Return whether the geometry exposed by this tile tree reference should cast shadows on other geometry. | |
imageryProvider Accessor ReadOnly | undefined | MapLayerImageryProvider | Returns the imagery provider for the tile tree. | |
treeOwner Accessor ReadOnly | TileTreeOwner | Return the owner of the TileTree to draw. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_isLoadingComplete Accessor Protected Inherited ReadOnly | boolean | MapLayerTileTreeReference | Override if additional asynchronous loading is required after the tile tree is successfully loaded, to indicate when that loading has completed. |
_layerIndex Protected Inherited | number | MapLayerTileTreeReference | |
_layerSettings Protected Inherited | MapLayerSettings | MapLayerTileTreeReference | |
_transparency Accessor Protected Inherited ReadOnly | undefined | number | MapLayerTileTreeReference | |
collectTileGeometry Inherited | (collector: TileGeometryCollector) => void | undefined | MapLayerTileTreeReference | If defined, supplies the implementation of collectTileGeometry. |
iModel Inherited | IModelConnection | MapLayerTileTreeReference | |
isGlobal Accessor Inherited ReadOnly | boolean | MapLayerTileTreeReference | Return whether this reference has global coverage. Mapping data is global and some non-primary models such as the OSM building layer have global coverage |
isLoadingComplete Accessor Inherited ReadOnly | boolean | MapLayerTileTreeReference | Return true if the tile tree is fully loaded and ready to draw. The default implementation returns true if the tile tree loading process completed (whether it resulted in success or failure). |
isOpaque Accessor Inherited ReadOnly | boolean | MapLayerTileTreeReference | Returns true if the associated map layer, including its sublayers, is opaque. |
layerIndex Accessor Inherited ReadOnly | number | MapLayerTileTreeReference | Returns the index of the map layer associated with the tile tree. |
layerName Accessor Inherited ReadOnly | string | MapLayerTileTreeReference | |
layerSettings Accessor Inherited | MapLayerSettings | MapLayerTileTreeReference | Returns the layer settings for the map layer. |
planarClipMaskPriority Accessor Inherited ReadOnly | number | MapLayerTileTreeReference | The PlanarClipMaskPriority of this tile tree used to determine which tile trees contribute to a clip mask when using PlanarClipMaskMode.Priority. |
transparency Accessor Inherited ReadOnly | undefined | number | MapLayerTileTreeReference | Returns the transparency value of the map layer. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.