MapLayerSettings Class
Abstract base class for normalized representation of a MapLayerProps for which values have been validated and default values have been applied where explicit values not defined. This class is extended by ImageMapLayerSettings and [ModelMapLayerSettings]] to create the settings for image and model based layers. One or more map layers may be included within MapImagerySettings object.
@see MapImagerySettings
Extended by
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<MapLayerProps>): MapLayerSettings Abstract | ||
toJSON(): MapLayerProps Abstract | ||
fromJSON(props: MapLayerProps): MapLayerSettings Static | Create a map layer settings from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
allSubLayersInvisible Accessor Abstract ReadOnly | boolean | ||
name Readonly | string | ||
source Accessor Abstract ReadOnly | string | Return a unique string identifying the layers source... | |
transparency Readonly | number | ||
transparentBackground Readonly | boolean | ||
visible Readonly | boolean |
Defined in
- core/common/src/MapLayerSettings.ts Line 214
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.