ModelMapLayerSettings Class
Normalized representation of a ModelMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. Model map layers are produced from models, typically from two dimensional geometry that may originate in a GIS system. One or more map layers may be included within MapImagerySettings object.
@see - MapImagerySettings
- ImageMapLayerSettings for image based map layer settings.
Extends
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<ModelMapLayerProps>): ModelMapLayerSettings | Create a copy of this MapLayerSettings, optionally modifying some of its properties. | |
toJSON(): ModelMapLayerProps | return JSON representation of this MapLayerSettings object | |
fromJSON(json: ModelMapLayerProps): ModelMapLayerSettings Static | Construct from JSON, performing validation and applying default values for undefined fields. |
Properties
Name | Type | Description | |
---|---|---|---|
allSubLayersInvisible Accessor ReadOnly | boolean | Return true if all sublayers are invisible (always false as model layers do not include sublayers). | |
modelId Readonly | string | ||
source Accessor ReadOnly | string | Return a unique string identifying the layers source... |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name Readonly | string | MapLayerSettings | |
transparency Readonly | number | MapLayerSettings | |
transparentBackground Readonly | boolean | MapLayerSettings | |
visible Readonly | boolean | MapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 486
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.