ImageMapLayerSettings Class
Normalized representation of a ImageMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. Image map layers are created from servers that produce images that represent map tiles. Map layers map also be represented by models. One or more map layers may be included within MapImagerySettings object.
@see - MapImagerySettings
- ModelMapLayerSettings for model based map layer settings.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<ImageMapLayerProps>): ImageMapLayerSettings | Create a copy of this MapLayerSettings, optionally modifying some of its properties. | |
collectQueryParams(): [key: string]: string | Collect all query parameters | |
getSubLayerChildren(subLayer: MapSubLayerSettings): undefined | MapSubLayerSettings[] | Return the children for a sublayer | |
isSubLayerVisible(subLayer: MapSubLayerSettings): boolean | Return true if sublayer is visible -- testing ancestors for visibility if they exist. | |
setCredentials(userName?: string, password?: string): void | ||
subLayerById(id?: SubLayerId): undefined | MapSubLayerSettings | Return a sublayer matching id -- or undefined if not found | |
toJSON(): ImageMapLayerProps | return JSON representation of this MapLayerSettings object | |
fromJSON(props: ImageMapLayerProps): ImageMapLayerSettings Static | Create a map layer settings from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
accessKey | MapLayerKey | undefined | ||
allSubLayersInvisible Accessor ReadOnly | boolean | Return true if all sublayers are invisible. | |
formatId Readonly | string | ||
password | string | undefined | ||
savedQueryParams | [key: string]: string | undefined | List of query parameters to append to the settings URL and persisted as part of the JSON representation. | |
source Accessor ReadOnly | string | Return a unique string identifying the layers source... | |
subLayers Readonly | MapSubLayerSettings[] | ||
unsavedQueryParams | [key: string]: string | undefined | List of query parameters that will get appended to the settings URL that should not be be persisted part of the JSON representation. | |
url Readonly | string | ||
userName | string | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name Readonly | string | MapLayerSettings | |
transparency Readonly | number | MapLayerSettings | |
transparentBackground Readonly | boolean | MapLayerSettings | |
visible Readonly | boolean | MapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 284
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.