BaseMapLayerSettings Class
A ImageMapLayerSettings that can serve as the base layer for a MapImagerySettings. The base layer supports all of the same options as any other layer, but also allows for simplified configuration based on a small set of known supported BackgroundMapProviders like Bing Maps. If the base layer was configured from such a provider, that information will be preserved and can be queried; this allows the imagery provider and/or type to be easily modified.
@see backgroundBase.
Extends
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<BaseMapLayerProps>): BaseMapLayerSettings | Create a copy of this layer. | |
toJSON(): BaseMapLayerProps | Convert this layer to its JSON representation. | |
fromJSON(props: BaseMapLayerProps): BaseMapLayerSettings Static | Create a base layer from its JSON representation. | |
fromProvider(provider: BackgroundMapProvider, options?: { invisible?: boolean, transparency?: number }): BaseMapLayerSettings Static | Create a base layer from a BackgroundMapProvider. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectQueryParams(): { T } Inherited | ImageMapLayerSettings | Collect all query parameters |
getSubLayerChildren(subLayer: MapSubLayerSettings): undefined | MapSubLayerSettings[] Inherited | ImageMapLayerSettings | Return the children for a sublayer |
isSubLayerVisible(subLayer: MapSubLayerSettings): boolean Inherited | ImageMapLayerSettings | Return true if sublayer is visible -- testing ancestors for visibility if they exist. |
setCredentials(userName?: string, password?: string): void Inherited | ImageMapLayerSettings | |
subLayerById(id?: SubLayerId): undefined | MapSubLayerSettings Inherited | ImageMapLayerSettings | Return a sublayer matching id -- or undefined if not found |
Properties
Name | Type | Description | |
---|---|---|---|
provider Accessor ReadOnly | undefined | BackgroundMapProvider | The provider from which this base layer was configured, if any. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessKey Inherited | MapLayerKey | undefined | ImageMapLayerSettings | |
allSubLayersInvisible Accessor Inherited ReadOnly | boolean | ImageMapLayerSettings | Return true if all sublayers are invisible. |
formatId Readonly Inherited | string | ImageMapLayerSettings | |
name Readonly Inherited | string | ImageMapLayerSettings | |
password Inherited | string | undefined | ImageMapLayerSettings | |
savedQueryParams Inherited | { T } | undefined | ImageMapLayerSettings | List of query parameters to append to the settings URL and persisted as part of the JSON representation. |
source Accessor Inherited ReadOnly | string | ImageMapLayerSettings | Return a unique string identifying the layers source... The URL for image layer or modelID for model layer |
subLayers Readonly Inherited | MapSubLayerSettings[] | ImageMapLayerSettings | |
transparency Readonly Inherited | number | ImageMapLayerSettings | |
transparentBackground Readonly Inherited | boolean | ImageMapLayerSettings | |
unsavedQueryParams Inherited | { T } | undefined | ImageMapLayerSettings | List of query parameters that will get appended to the settings URL that should not be be persisted part of the JSON representation. |
url Readonly Inherited | string | ImageMapLayerSettings | |
userName Inherited | string | undefined | ImageMapLayerSettings | |
visible Readonly Inherited | boolean | ImageMapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 553
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.