BackgroundMapProvider Class
Describes one of a small set of standard, known suppliers of background map imagery as part of a BaseMapLayerSettings.
Methods
Name | Description | |
---|---|---|
clone(changedProps: BackgroundMapProviderProps): BackgroundMapProvider | Produce a copy of this provider with identical properties except for those explicitly specified by changedProps . |
|
equals(other: BackgroundMapProvider): boolean | Return true if this provider is equivalent to other . |
|
toJSON(): BackgroundMapProviderProps | Convert this provider to its JSON representation. | |
fromJSON(props: BackgroundMapProviderProps): BackgroundMapProvider Static | Create a provider from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
name Readonly | BackgroundMapProviderName | The name of the provider. | |
type Readonly | BackgroundMapType | The type of map imagery provided. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.