BaseMapLayerProps Interface
JSON representation of a BaseMapLayerSettings.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
provider | BackgroundMapProviderProps | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
formatId Inherited | string | ImageMapLayerProps | Identifies the map layers source. |
name Inherited | string | ImageMapLayerProps | A user-friendly name for the layer. |
queryParams Inherited | { T } | undefined | ImageMapLayerProps | List of query parameters that will get appended to the source. |
subLayers Inherited | MapSubLayerProps[] | undefined | ImageMapLayerProps | Source layers. |
transparency Inherited | number | undefined | ImageMapLayerProps | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, |
transparentBackground Inherited | boolean | undefined | ImageMapLayerProps | True to indicate background is transparent. |
url Inherited | string | ImageMapLayerProps | URL |
visible Inherited | boolean | undefined | ImageMapLayerProps | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 541
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.